re = /\s+([:;»!?\/])|([«])\s+/
str = 'Salut ! Ca va ?
« Comme un lundi » ; comme on dit...
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end