#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s){[^}]+}"
Local $sString = "{Частину першу статті 3 доповнено абзацом другим згідно із Законом № 1472-VIII від 14.07.2016}" & @CRLF & _
"{Частину першу статті 3 доповнено абзацом другим згідно із Законом № 1472-VIII від 14.07.2016}" & @CRLF & _
"{Частину першу статті 3 доповнено абзацом другим згідно із Законом № 1472-VIII від 14.07.2016}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")