// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s){[^}]+}").unwrap();
let string = "{Частину першу статті 3 доповнено абзацом другим згідно із Законом № 1472-VIII від 14.07.2016}
{Частину першу статті 3 доповнено абзацом другим згідно із Законом № 1472-VIII від 14.07.2016}
{Частину першу статті 3 доповнено абзацом другим згідно із Законом № 1472-VIII від 14.07.2016}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}