re = /{[^}]+}/
str = '{Частину першу статті 3 доповнено абзацом другим згідно із Законом № 1472-VIII від 14.07.2016}
{Частину першу статті 3 доповнено абзацом другим згідно із Законом № 1472-VIII від 14.07.2016}
{Частину першу статті 3 доповнено абзацом другим згідно із Законом № 1472-VIII від 14.07.2016}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end