const regex = /(?:\b:amd\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b:amd\\b)', 'gm')
const str = `libsystemd0:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), libkmod2:amd64 (24-1ubuntu3.4, 24-1ubuntu3.5), udev:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), kmod:amd64 (24-1ubuntu3.4, 24-1ubuntu3.5), libudev1:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), systemd-sysv:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), libpam-systemd:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), systemd:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), libnss-systemd:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), base-files:amd64 (10.1ubuntu2.8, 10.1ubuntu2.9)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}