import re
regex = re.compile(r"(?:\b:amd\b)", flags=re.MULTILINE)
test_str = "libsystemd0:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), libkmod2:amd64 (24-1ubuntu3.4, 24-1ubuntu3.5), udev:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), kmod:amd64 (24-1ubuntu3.4, 24-1ubuntu3.5), libudev1:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), systemd-sysv:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), libpam-systemd:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), systemd:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), libnss-systemd:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), base-files:amd64 (10.1ubuntu2.8, 10.1ubuntu2.9)"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")