$re = '/(?:\b:amd\b)/m';
$str = 'libsystemd0:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), libkmod2:amd64 (24-1ubuntu3.4, 24-1ubuntu3.5), udev:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), kmod:amd64 (24-1ubuntu3.4, 24-1ubuntu3.5), libudev1:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), systemd-sysv:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), libpam-systemd:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), systemd:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), libnss-systemd:amd64 (237-3ubuntu10.41, 237-3ubuntu10.42), base-files:amd64 (10.1ubuntu2.8, 10.1ubuntu2.9)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);