import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.(?![a-z0-9]{3,4}$)";
final String string = "names.with.periods.and.extension\n"
+ "names#with$Special&chars*yuhyuh.yuh.yuh..yuhyuh\n"
+ "Normal . Name . with 123 some numbers.mp3\n"
+ "Normal . Name . with 123 some numbers.mpeg\n"
+ "Normal . Name . with 123 ..some . numbers mpeg.123";
final String subst = "@@@";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}