using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^step\s*(\d+)\s*(.*?)\s*(?=^step\s*\d|\Z)";
string input = @"This is the first line of the file.
here we tell you to make a tea.
step 1
Pour more than enough water for a cup of tea into a regular pot, and bring it to a boil.
step
2
This will prevent the steeping water from dropping in temperature as soon as it is poured in.
step 3
When using tea bags, the measuring has already been done for you - generally it's one tea bag per cup.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}