$re = '/^step\s*(\d+)\s*(.*?)\s*(?=^step\s*\d|\Z)/ms';
$str = 'This is the first line of the file.
here we tell you to make a tea.
step 1
Pour more than enough water for a cup of tea into a regular pot, and bring it to a boil.
step
2
This will prevent the steeping water from dropping in temperature as soon as it is poured in.
step 3
When using tea bags, the measuring has already been done for you - generally it\'s one tea bag per cup.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);