use strict;
my $str = 'This is the first line of the file.
here we tell you to make a tea.
step 1
Pour more than enough water for a cup of tea into a regular pot, and bring it to a boil.
step
2
This will prevent the steeping water from dropping in temperature as soon as it is poured in.
step 3
When using tea bags, the measuring has already been done for you - generally it\'s one tea bag per cup.';
my $regex = qr/^step\s*(\d+)\s*(.*?)\s*(?=^step\s*\d|\Z)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}