package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(bob)+`)
var str = `bobbobbobbob bab babob bobab bobbob
bobbobababobobbobaobaobabbobobobobobbobbobbob`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}