re = /(bob)+/
str = 'bobbobbobbob bab babob bobab bobbob
bobbobababobobbobaobaobabbobobobobobbobbobbob'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end