$re = '/(bob)+/';
$str = 'bobbobbobbob bab babob bobab bobbob
bobbobababobobbobaobaobabbobobobobobbobbobbob';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);