using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^#(?!F+$)(?:[A-Fa-f0-9]{6}|[A-Fa-f0-9]{3})$";
string input = @"#FFFFFF
#FFFasdfsdfg
#F00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}