$re = '/^#(?!F+$)(?:[A-Fa-f0-9]{6}|[A-Fa-f0-9]{3})$/m';
$str = '#FFFFFF
#FFFasdfsdfg
#F00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);