const regex = /^#(?!F+$)(?:[A-Fa-f0-9]{6}|[A-Fa-f0-9]{3})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#(?!F+$)(?:[A-Fa-f0-9]{6}|[A-Fa-f0-9]{3})$', 'gm')
const str = `#FFFFFF
#FFFasdfsdfg
#F00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}