re = /(?:\d{1,2},)?\d{1,3}\.\d{2}/m
str = '0.01
99.34
4,234.01
1,234
23.0
99,999.99
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end