using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<font>default|[[:alpha:] ]+)(?>@(?<size>\d+))?(?>\+(?<decors>strikeout|bold|italic))*$";
string input = @"default@10+strikeout+bold+italic
default+strikeout+bold+italic
default
default@11
Aria l@11";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}