$re = '/^(?<font>default|[[:alpha:] ]+)(?>@(?<size>\d+))?(?>\+(?<decors>strikeout|bold|italic))*$/m';
$str = 'default@10+strikeout+bold+italic
default+strikeout+bold+italic
default
default@11
Aria l@11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);