re = /^(?<font>default|[[:alpha:] ]+)(?>@(?<size>\d+))?(?>\+(?<decors>strikeout|bold|italic))*$/m
str = 'default@10+strikeout+bold+italic
default+strikeout+bold+italic
default
default@11
Aria l@11'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end