using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""\|37\|"":\""(\d+)";
string input = @"{""|1|"":""A"",""|2|"":""B"",""|37|"":""4234235"",""|4|"":""C""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}