package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"\|37\|":\"(\d+)`)
var str = `{"|1|":"A","|2|":"B","|37|":"4234235","|4|":"C"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}