$re = '/"\|37\|":\"(\d+)/m';
$str = '{"|1|":"A","|2|":"B","|37|":"4234235","|4|":"C"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);