#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(?:\[?color=#[0-9a-f]{6}]?)|(?:\[?color=rgb\(\d{1,3}, \d{1,3}, \d{1,3}\)]?)|\[?\/color]?"
Local $sString = "[color=#FF0000].[/color] content content content content content content [color=#FF0000]content [/color]content content[color=#FF0000], [/color]content content. content content content content [color=#FF0000],[/color] content content content. content [color=#FF0000]content[/color] content content content [color=#FF0000],[/color][color=#FF0000]content[/color] content [color=#FF0000],[/color][color=#FF0000]content content content content content[/color], content content content content content content content content. content content[color=#FF0000]-[/color] content content content content [color=#FF0000]content[/color] content ? content content content content content content content content content content content content content [color=#FF0000]-[/color]content 1 июня[color=#FF0000], [/color]например или нет как начало отпуска? [color=#FF0000]content content content content content.Расставляйте запятые,чтобы предложение не было сплошным набором слов. content content content content -content или вашего друга?А то по вашей манере написания это непонятно.content.[/color[color=#FF0000][color=#FF0000][color=#FFFF80][/color]" & @CRLF & _
"" & @CRLF & _
"j6y7 [/color dsad klkl;o /color] yuuyu colortest /color color. dsadas" & @CRLF & _
"opopp" & @CRLF & _
"[CENTER][B][SIZE=7]lorem psum text.[/SIZE][/B]" & @CRLF & _
"[SIZE=7]" & @CRLF & _
"[B]lorem psum text lorem psum text" & @CRLF & _
"lorem psum text," & @CRLF & _
"lorem psum text lorem psum text lorem psum text." & @CRLF & _
"[/B]" & @CRLF & _
"[B]lorem psum text lorem psum text lorem psum text" & @CRLF & _
"" & @CRLF & _
"lorem psum text lorem psum text[/B]" & @CRLF & _
"" & @CRLF & _
"[B]lorem psum text lorem psum text:[/B]" & @CRLF & _
"" & @CRLF & _
"[COLOR=rgb(65, 168, 95)][B]- lorem psum text lorem psum text lorem psum text" & @CRLF & _
"[/B][/SIZE]" & @CRLF & _
"[B][COLOR=rgb(65, 168, 95)][SIZE=7]- lorem psum text lorem psum text lorem psum text" & @CRLF & _
"[/SIZE][/B]" & @CRLF & _
"[SIZE=7][B]- lorem psum text lorem psum text lorem psum text lorem psum text[/B]" & @CRLF & _
"[COLOR=rgb(147, 101, 184)]" & @CRLF & _
"[ATTACH type="full"]1653[/ATTACH]" & @CRLF & _
"[B]lorem psum text lorem psum text[/B]" & @CRLF & _
"[COLOR=rgb(147, 101, 184)]" & @CRLF & _
"[B]lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text." & @CRLF & _
"" & @CRLF & _
"lorem psum text lorem psum text lorem psum text lorem psum text.[/B]" & @CRLF & _
"" & @CRLF & _
"[COLOR=rgb(235, 107, 86)][B]lorem psum text lorem psum text lorem psum textlorem psum text:" & @CRLF & _
"" & @CRLF & _
"[URL unfurl="true"]https://domain.com[/URL]" & @CRLF & _
"" & @CRLF & _
"lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text[/B][COLOR=rgb(147, 101, 184)][B]" & @CRLF & _
"" & @CRLF & _
"lorem psum text lorem psum text lorem psum text lorem psum text.[/B]" & @CRLF & _
"" & @CRLF & _
"[COLOR=rgb(251, 160, 38)][B]lorem psum text lorem psum text lorem psum text lorem psum text" & @CRLF & _
"lorem psum text. [/B]" & @CRLF & _
"[/SIZE][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][/CENTER][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)