using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\[?color=#[0-9a-f]{6}]?)|(?:\[?color=rgb\(\d{1,3}, \d{1,3}, \d{1,3}\)]?)|\[?\/color]?";
string substitution = @"";
string input = @"[color=#FF0000].[/color] content content content content content content [color=#FF0000]content [/color]content content[color=#FF0000], [/color]content content. content content content content [color=#FF0000],[/color] content content content. content [color=#FF0000]content[/color] content content content [color=#FF0000],[/color][color=#FF0000]content[/color] content [color=#FF0000],[/color][color=#FF0000]content content content content content[/color], content content content content content content content content. content content[color=#FF0000]-[/color] content content content content [color=#FF0000]content[/color] content ? content content content content content content content content content content content content content [color=#FF0000]-[/color]content 1 июня[color=#FF0000], [/color]например или нет как начало отпуска? [color=#FF0000]content content content content content.Расставляйте запятые,чтобы предложение не было сплошным набором слов. content content content content -content или вашего друга?А то по вашей манере написания это непонятно.content.[/color[color=#FF0000][color=#FF0000][color=#FFFF80][/color]
j6y7 [/color dsad klkl;o /color] yuuyu colortest /color color. dsadas
opopp
[CENTER][B][SIZE=7]lorem psum text.[/SIZE][/B]
[SIZE=7]
[B]lorem psum text lorem psum text
lorem psum text,
lorem psum text lorem psum text lorem psum text.
[/B]
[B]lorem psum text lorem psum text lorem psum text
lorem psum text lorem psum text[/B]
[B]lorem psum text lorem psum text:[/B]
[COLOR=rgb(65, 168, 95)][B]- lorem psum text lorem psum text lorem psum text
[/B][/SIZE]
[B][COLOR=rgb(65, 168, 95)][SIZE=7]- lorem psum text lorem psum text lorem psum text
[/SIZE][/B]
[SIZE=7][B]- lorem psum text lorem psum text lorem psum text lorem psum text[/B]
[COLOR=rgb(147, 101, 184)]
[ATTACH type=""full""]1653[/ATTACH]
[B]lorem psum text lorem psum text[/B]
[COLOR=rgb(147, 101, 184)]
[B]lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text.
lorem psum text lorem psum text lorem psum text lorem psum text.[/B]
[COLOR=rgb(235, 107, 86)][B]lorem psum text lorem psum text lorem psum textlorem psum text:
[URL unfurl=""true""]https://domain.com[/URL]
lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text[/B][COLOR=rgb(147, 101, 184)][B]
lorem psum text lorem psum text lorem psum text lorem psum text.[/B]
[COLOR=rgb(251, 160, 38)][B]lorem psum text lorem psum text lorem psum text lorem psum text
lorem psum text. [/B]
[/SIZE][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][/CENTER][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}