# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\[?color=#[0-9a-f]{6}]?)|(?:\[?color=rgb\(\d{1,3}, \d{1,3}, \d{1,3}\)]?)|\[?\/color]?"
test_str = ("[color=#FF0000].[/color] content content content content content content [color=#FF0000]content [/color]content content[color=#FF0000], [/color]content content. content content content content [color=#FF0000],[/color] content content content. content [color=#FF0000]content[/color] content content content [color=#FF0000],[/color][color=#FF0000]content[/color] content [color=#FF0000],[/color][color=#FF0000]content content content content content[/color], content content content content content content content content. content content[color=#FF0000]-[/color] content content content content [color=#FF0000]content[/color] content ? content content content content content content content content content content content content content [color=#FF0000]-[/color]content 1 июня[color=#FF0000], [/color]например или нет как начало отпуска? [color=#FF0000]content content content content content.Расставляйте запятые,чтобы предложение не было сплошным набором слов. content content content content -content или вашего друга?А то по вашей манере написания это непонятно.content.[/color[color=#FF0000][color=#FF0000][color=#FFFF80][/color]\n\n"
"j6y7 [/color dsad klkl;o /color] yuuyu colortest /color color. dsadas\n"
"opopp\n"
"[CENTER][B][SIZE=7]lorem psum text.[/SIZE][/B]\n"
"[SIZE=7]\n"
"[B]lorem psum text lorem psum text\n"
"lorem psum text,\n"
"lorem psum text lorem psum text lorem psum text.\n"
"[/B]\n"
"[B]lorem psum text lorem psum text lorem psum text\n\n"
"lorem psum text lorem psum text[/B]\n\n"
"[B]lorem psum text lorem psum text:[/B]\n\n"
"[COLOR=rgb(65, 168, 95)][B]- lorem psum text lorem psum text lorem psum text\n"
"[/B][/SIZE]\n"
"[B][COLOR=rgb(65, 168, 95)][SIZE=7]- lorem psum text lorem psum text lorem psum text\n"
"[/SIZE][/B]\n"
"[SIZE=7][B]- lorem psum text lorem psum text lorem psum text lorem psum text[/B]\n"
"[COLOR=rgb(147, 101, 184)]\n"
"[ATTACH type=\"full\"]1653[/ATTACH]\n"
"[B]lorem psum text lorem psum text[/B]\n"
"[COLOR=rgb(147, 101, 184)]\n"
"[B]lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text.\n\n"
"lorem psum text lorem psum text lorem psum text lorem psum text.[/B]\n\n"
"[COLOR=rgb(235, 107, 86)][B]lorem psum text lorem psum text lorem psum textlorem psum text:\n\n"
"[URL unfurl=\"true\"]https://domain.com[/URL]\n\n"
"lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text lorem psum text[/B][COLOR=rgb(147, 101, 184)][B]\n\n"
"lorem psum text lorem psum text lorem psum text lorem psum text.[/B]\n\n"
"[COLOR=rgb(251, 160, 38)][B]lorem psum text lorem psum text lorem psum text lorem psum text\n"
"lorem psum text. [/B]\n"
"[/SIZE][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][/CENTER][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)][COLOR=rgb(251, 160, 38)]")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.