const regex = /(?<jobRunTimeMs1>\d+)ms|(?<jobRunTimeS2>\d+)s(?<jobRunTimeMs2>\d+)ms|(?<jobRunTimeM3>\d+)m(?<jobRunTimeS3>\d+)s(?<jobRunTimeMs3>\d+)ms/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<jobRunTimeMs1>\\d+)ms|(?<jobRunTimeS2>\\d+)s(?<jobRunTimeMs2>\\d+)ms|(?<jobRunTimeM3>\\d+)m(?<jobRunTimeS3>\\d+)s(?<jobRunTimeMs3>\\d+)ms', 'gm')
const str = `709ms
59s709ms
1m59s709ms`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}