use strict;
my $str = 'asdf[d4:asdf]';
my $regex = qr/(.*)(\[(((?<=\[)..*:|(?<=\[).))(.*)\])/p;
my $subst = '$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";