$re = '/(.*)(\[(((?<=\[)..*:|(?<=\[).))(.*)\])/';
$str = 'asdf[d4:asdf]';
$subst = "$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;