#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) ( # (1 start)" & @CRLF & _
" \( \( PERS \) " & @CRLF & _
" (?: \w \s* )+" & @CRLF & _
" \) " & @CRLF & _
" (?:" & @CRLF & _
" \s* " & @CRLF & _
" (?!" & @CRLF & _
" \( \( PERS \) " & @CRLF & _
" (?: \w \s* )+" & @CRLF & _
" \) " & @CRLF & _
" )" & @CRLF & _
" \b " & @CRLF & _
" \w+ " & @CRLF & _
" ){0,2}" & @CRLF & _
" ) # (1 end)" & @CRLF & _
" | (?<! \S )" & @CRLF & _
" ( le ) # (2)" & @CRLF & _
" (?! \S )" & @CRLF & _
""
Local $sString = "le ((VERB)empujé) hasta ((VERB)dejarle) en ese lugar. A ((PERS)Marcos) le ((VERB)dijeron) y luego le ((VERB)ayudo)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")