using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" ( # (1 start)
\( \( PERS \)
(?: \w \s* )+
\)
(?:
\s*
(?!
\( \( PERS \)
(?: \w \s* )+
\)
)
\b
\w+
){0,2}
) # (1 end)
| (?<! \S )
( le ) # (2)
(?! \S )
";
string input = @"le ((VERB)empujé) hasta ((VERB)dejarle) en ese lugar. A ((PERS)Marcos) le ((VERB)dijeron) y luego le ((VERB)ayudo)";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}