const regex = new RegExp(' ( # (1 start)
\\( \\( PERS \\)
(?: \\w \\s* )+
\\)
(?:
\\s*
(?!
\\( \\( PERS \\)
(?: \\w \\s* )+
\\)
)
\\b
\\w+
){0,2}
) # (1 end)
| (?<! \\S )
( le ) # (2)
(?! \\S )
', 'g')
const str = `le ((VERB)empujé) hasta ((VERB)dejarle) en ese lugar. A ((PERS)Marcos) le ((VERB)dijeron) y luego le ((VERB)ayudo)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}