# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\{\\/\*DELETE}((?:(?!\{\\/\*DELETE})[\s\S])*?)\{DELETE\*\\/}//g;t' <<< "Keep1
{/*DELETE}
Delete1a
{/*DELETE}
Delete2
{DELETE*/}
Delete1b
{DELETE*/}
Keep2
{/*DELETE}
Delete3
{DELETE*/}
Keep3"