import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\/\\*DELETE\\}((?:(?!\\{\\/\\*DELETE\\})[\\s\\S])*?)\\{DELETE\\*\\/\\}";
final String string = "Keep1\n"
+ "{/*DELETE}\n"
+ "Delete1a\n"
+ " {/*DELETE}\n"
+ " Delete2\n"
+ " {DELETE*/}\n"
+ "Delete1b\n"
+ "{DELETE*/}\n"
+ "Keep2\n"
+ "{/*DELETE}\n"
+ "Delete3\n"
+ "{DELETE*/}\n"
+ "Keep3";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}