const regex = /\{\/\*DELETE}((?:(?!\{\/\*DELETE})[\s\S])*?)\{DELETE\*\/}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\\/\\*DELETE}((?:(?!\\{\\\/\\*DELETE})[\\s\\S])*?)\\{DELETE\\*\\\/}', 'g')
const str = `Keep1
{/*DELETE}
Delete1a
{/*DELETE}
Delete2
{DELETE*/}
Delete1b
{DELETE*/}
Keep2
{/*DELETE}
Delete3
{DELETE*/}
Keep3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);