package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*(ecr|lambda).*.amazonaws.com`)
var str = `https://123456789012.dkr.ecr.us-west-2.amazonaws.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}