re = /.*(ecr|lambda).*.amazonaws.com/m
str = 'https://123456789012.dkr.ecr.us-west-2.amazonaws.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end