$re = '/.*(ecr|lambda).*.amazonaws.com/m';
$str = 'https://123456789012.dkr.ecr.us-west-2.amazonaws.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);