using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_+\d+_*";
string substitution = @"";
string input = @"""F1_6346346346_TrainTest_53453465.rds"", ""F1_64575687357_FunctionTest_747434534.rds"", ""F3F4_546345647678_TrainTest_453463654.rds"" ";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}