re = /_+\d+_*/m
str = '"F1_6346346346_TrainTest_53453465.rds", "F1_64575687357_FunctionTest_747434534.rds", "F3F4_546345647678_TrainTest_453463654.rds" '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result