const regex = /(www.)?dom-?ains?.(tld1|tld2|tld3|tld4)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(www.)?dom-?ains?.(tld1|tld2|tld3|tld4)', 'gm')
const str = `www.domain.tld1
domain.tld2
www.dom-ain.tld3
www.domains.tld4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}