$re = '/(www.)?dom-?ains?.(tld1|tld2|tld3|tld4)/m';
$str = 'www.domain.tld1
domain.tld2
www.dom-ain.tld3
www.domains.tld4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);