import re
regex = re.compile(r"(www.)?dom-?ains?.(tld1|tld2|tld3|tld4)", flags=re.MULTILINE)
test_str = ("www.domain.tld1\n"
"domain.tld2\n"
"www.dom-ain.tld3\n"
"www.domains.tld4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")