import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[\\pL\\h]+,)\\h*\\Kдругой,\\h*.+$";
final String string = "различный, разный, другой, отличный от, необычный, неодинаковый, непохожий, не такой\n"
+ "втор ой, другой, второй, секунда, вторым номером, подкреплять\n"
+ "тут может быть любое количество слов главное чтобы до запятой, другой, второй, секунда, подкреплять\n"
+ "другой, остальные, иной, другой, иначе";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}