use strict;
my $str = 'различный, разный, другой, отличный от, необычный, неодинаковый, непохожий, не такой
втор ой, другой, второй, секунда, вторым номером, подкреплять
тут может быть любое количество слов главное чтобы до запятой, другой, второй, секунда, подкреплять
другой, остальные, иной, другой, иначе';
my $regex = qr~^(?:[\pL\h]+,)\h*\Kдругой,\h*.+$~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}