re = /^(?:[\pL\h]+,)\h*\Kдругой,\h*.+$/m
str = 'различный, разный, другой, отличный от, необычный, неодинаковый, непохожий, не такой
втор ой, другой, второй, секунда, вторым номером, подкреплять
тут может быть любое количество слов главное чтобы до запятой, другой, второй, секунда, подкреплять
другой, остальные, иной, другой, иначе'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end