$re = '/\bTOOL_([A-Z]+)\h+=\h+(?:(\d+)|("\w+"))/m';
$str = 'TOOL_ID = 1
TOOL_NAME = "Calc"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);