re = /\bTOOL_([A-Z]+)\h+=\h+(?:(\d+)|("\w+"))/m
str = 'TOOL_ID = 1
TOOL_NAME = "Calc"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end