// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\bTOOL_([A-Z]+)\h+=\h+(?:(\d+)|("\w+"))"#).unwrap();
let string = "TOOL_ID = 1
TOOL_NAME = \"Calc\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}